Announcement

Collapse
No announcement yet.

Putting a blend pot in a Baggs equipped Ibanez S520X and several technical issues.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Caleb_Elling
    replied
    Hey Daniel,
    That system wasn't ever designed to blend the two signals together. The Double Edge preamp/circuit was made custom for Ibanez, and blending the signals was just never a part of the design. Since there isn't a blending circuit, there really isn't a place to add a blend pot where it will work as well as it does in systems like the CTRL-X. The hotter EMG pickups will likely cause some pretty severe loading without the right kind of circuit.

    Unfortunately, since LR Baggs has very strict policy against distributing schematics, there isn't anything I can do to help you modify this circuit to give it the function you're looking for. You can definitely try replacing the DPDT switch with a dual-concentric pot, but I don't think it will give you the quality that you're looking for.

    Leave a comment:


  • nasha
    replied
    Wiring diagram for Ibanez with Seymour Duncan & L.R. Baggs pickups

    Hi Caleb and anyone interested,

    The results are promising. The diagram works as expected, which you will find here:

    SH10 BAGGS.jpg

    However, there's still no option to output both the mag and piezo signals simultaneously, due to the 2-way switch. I thought the yellow cable would act as a bypass, but unfortunately, it doesn't.

    If you could help me with swapping 2-way switch for the blend pot, that would be very much appreciated!


    Thanks in advance,

    Daniel

    Leave a comment:


  • Caleb_Elling
    replied
    Hey nasha,
    I just replied to your email.

    If you didn't receive it, let me know.

    Leave a comment:


  • Putting a blend pot in a Baggs equipped Ibanez S520X and several technical issues.

    Dear support,

    I've recently bought an Ibanez S520x; an axe with dual outputs. But there are some issues.
    • The high E doesn't produce any sound at all.
    • There's not a 3-way but a 2-way switch attached to the control-x. So there's currently no way to blend the two signals.
    • The yellow cable is not attached.
    • I'm switching from active (EMG) to passive (Duncan) magnetic pickups.
    • I would love to be able to blend seamlessly between the Duncans and the piezos over dual outputs.


    -So what's wrong with the high E? Do I have to lift up the saddle to check for debris? How do I do this? If that isn't it, could the crystal actually be dead, and are there single replacements available for shipment to the Netherlands?
    -Because only the control-x would need power from the battery: Is there a port on the control-x where I can attach the black wire directly, or should it be attached to the output instead?
    -And can I swap out the 2-way switch for a blend pot in order to achieve a seamless blend? If so, where do the orange wire, two red and two black wires go on this blend pot?

    Any questions answered would truly be of great help!

    Thank you in advance!
    Last edited by nasha; 07-05-2016, 02:14 AM.
Working...
X