Announcement

Collapse
No announcement yet.

Stage Pro Element Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stage Pro Element Help

    Hello,

    I have a Breedlove Stage J350/EF-12. My active element has been acting up. When I power it up it lights up in its normal sequence but the green light just flashes
    continuously. I thought at first it was a dead battery so I replaced it and it still doing the same thing. the tuner doesn't respond, nothing.

    Please help.

    Thanks for any feedback.
    Last edited by mmmgrow; 09-12-2012, 02:25 PM.

  • #2
    The flashing green light signals that the Tuner is engaged. If the Tuner is on, the preamp won't pass signal to the output.

    Comment


    • #3
      Thanks for the reply.

      The tuner is engaged but it is registering when I try to tune. If I play the E or B very hard it will recognize it but no other strings register.

      Comment


      • #4
        If you disengage the tuner, do you get any signal from the system?

        Comment


        • #5
          No. I get nothing

          I mispoke. The tuner does not register input from the strings

          Comment


          • #6
            Update:

            Was playing acoustic (because my Stagepro element was not working) earlier and on a break I had it on my back when the strap gave way and she dropped 8+/- inches onto the
            carpet. I was horrified and simultaneously calm, luck and quick reflexes prevailed, she was in a vertical position on the journey down, only the smallest point making contact with
            the ground, giving me enough time to control her wild was as she hung in that vertical position after the first hit. I calmly embraced her as she tried to get away.

            The jolt did pop the battery compartment out. When I put it back in and engaged the tuner everything was fine! Plugged her into the amp and she sounded glorious!

            So lucky. I'll will update if there are any more problems. I expect none.

            Comment


            • #7
              I just bought a Larrivee L-05 with the stage pro anthem pickup on it. When I try to tune the guitar it will only flash green light and does not register any of the strings when I play them? the guitar works fine plugged in just having problems with the tuner. Any suggestions? Thanks!!

              Comment


              • #8
                Problems with tuner

                Originally posted by Caleb_Elling View Post
                If you disengage the tuner, do you get any signal from the system?
                I just bought a Larrivee L-05 with the stage pro anthem pickup on it. When I try to tune the guitar it will only flash green light and does not register any of the strings when I play them? the guitar works fine plugged in just having problems with the tuner. Any suggestions? Thanks!!

                Comment


                • #9
                  Jman,
                  The flashing green light means that the tuner is not receiving any signal. If your Anthem sounds good when you plug it in, that means that your pickups are working, but you may have a faulty tuner.

                  Comment

                  Working...
                  X