Announcement

Collapse
No announcement yet.

Element undersaddle pickup humming

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Element undersaddle pickup humming

    I just received two Element active undersaddle pickups for two guitars that I own. I installed both, and one of them was humming A LOT, while the other works perfectly. I took both pickups back out, and noticed that on the one that is humming, the small, exposed metal at the end of the undersaddle "string" was missing. I am assuming this is some sort of grounding device? Is this something that I can fix without sending the pick up back...or will this require a swap out?
    Last edited by mrdissinger; 09-18-2014, 07:19 AM.

  • #2
    Hi mrdissinger,
    I've added a picture below that shows what the Element should look like. If the black dot on the end is not there (top side of pickup), or if the tip is frayed, then you would definitely need to get a replacement pickup.

    If that is the case, then that would be very unusual. Unless the pickup was bought used, I can't see any reason why that would have happened during the shipping or installation process. Mishandling aside.

    Let me know. Thanks for getting in touch!

    20140918_090330.jpg

    Comment


    • #3
      Originally posted by Caleb_Elling View Post
      Hi mrdissinger,
      I've added a picture below that shows what the Element should look like. If the black dot on the end is not there (top side of pickup), or if the tip is frayed, then you would definitely need to get a replacement pickup.

      If that is the case, then that would be very unusual. Unless the pickup was bought used, I can't see any reason why that would have happened during the shipping or installation process. Mishandling aside.

      Let me know. Thanks for getting in touch!

      [ATTACH=CONFIG]83[/ATTACH]
      Yeah...that is what I thought too. The black dot is not at the end. It looks like it has been cut or stripped. The install on the first pickup went totally smoothly, so I know I didn't damage it during install. Is this something that LR Baggs would replace, or am I out of luck?

      Thanks for your help!!!

      Comment


      • #4
        When and where did you purchase the system?

        Feel free to reply via email if you would like to keep any further information more private. You can reach me directly at [email protected].

        Comment

        Working...
        X