Announcement

Collapse
No announcement yet.

Installing iMix

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Caleb_Elling
    replied
    Shoot me an email at [email protected], and I'll help you out.

    Leave a comment:


  • M1A
    replied
    It did go out when I unplugged the output harness. Looks like I'll need a new one.

    Thanks for the help.

    Leave a comment:


  • Caleb_Elling
    replied
    The light should turn off when the guitar is unplugged. If the light stays on, then try unplugging the grey output harness from the preamp. If the light goes off at that point, there's probably a short in the jack itself.

    Leave a comment:


  • M1A
    replied
    Thanks that worked. One more question. The light on the preamp stays on all the time, even when there's no cord plugged in. Is that normal? Thanks.

    Leave a comment:


  • Caleb_Elling
    replied
    Hey M1A,
    The white slot has a clamp that you need to open before the cable will fit in. If you use your fingernail to lift up on the two ends of the white connector, it will pop up. Then you can put the cable in and press the clamp/connector back down to lock it in place.

    Leave a comment:


  • M1A
    started a topic Installing iMix

    Installing iMix

    I'm installing an iMix system and can't figure out how to install the flat cable to the preamp and controller. Is it just supposed to slide into the slot? Thanks.
    You do not have permission to view this gallery.
    This gallery has 1 photos.
Working...
X