Announcement

Collapse
No announcement yet.

Battery runs down on my Anthem tru-mic. Seems always engaged on

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Caleb_Elling
    replied
    It's probably a short in the preamp of some kind. Since I haven't seen that issue specifically, I can't say for sure.

    If you want to email me at [email protected], I can work with you to try and get this repaired or replaced for you.

    Leave a comment:


  • martie6621
    replied
    It s a new 2014 J200. It was that way when I got it. Could it be a pre-amp short?

    Leave a comment:


  • Caleb_Elling
    replied
    Hey Martie,
    I can't say I've seen that before. I've seen a couple of situations with battery drain, but never on where the batt check was always on. That will definitely drain the battery though.

    How long have you had the Anthem installed? Is this a new issue, or has it been going on for a while?

    Leave a comment:


  • Battery runs down on my Anthem tru-mic. Seems always engaged on

    I have a J200 which came with a Tru Mic Anthem system. There seems to be a problem with the batter always being "on" even when there is no cable connected to the guitar. i notice that the green LEDs are always lit up. I can depress and release the small battery test button and the LEDs go off but then they come right back on again. This then runs the battery down even when the guitar is in the case and not being played.

    Anyone else had this problem or a solution? Much appreciate any help.

    Thanks

    Martie
Working...
X