Announcement

Collapse
No announcement yet.

Newly Installed Lyric Mic system does not work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newly Installed Lyric Mic system does not work

    I just installed the Lyric mic system in a D12-35 Martin guitar and was very disappointed that the Lyric is totally non functioning.
    I tried different batteries and plug in cables but it just doesn't work, there is no signal going to the amp.
    I have installed a Lyric in another Martin and it works very good which is why I went with the Lyric for this application as well.
    In the past I have also installed numerous other systems in different guitars all with good results.
    I have sent an email to the support department at LR Baggs but I haven't received a reply yet(one day ago).
    I am hoping we can resolve this issue quickly and be done with it and would appreciate advice on how to proceed.
    The installation was without incident other than the plug jack being a little short for the tail block disallowing the use of the internal washers and nut.
    I have read other posts confirming that this is a problem with the older Martins(mine is a 68).
    I think for the next install on this guitar I would try removing a little wood from the tail block with a Dremel tool.
    But first I need a working pickup.

    Thanks
    Ed

  • #2
    Hey Ed,
    I understand that Bryan gave you a call earlier this morning. If we can help out with anything else, just let us know.

    Comment


    • #3
      Thanks Caleb

      Hi Caleb,
      Yes Bryan did give me a call this morning and said that i could return the Lyric to LR Baggs but suggested that I contact the seller to see if they will do an exchange as it might be faster.
      I have contacted the seller and I will see what they have to say and then I can proceed with the next step.
      Thanks to you and Bryan for your help and I will let you know when I hear from the seller.

      Ed

      Comment


      • #4
        Originally posted by Ed2014 View Post
        Hi Caleb,
        Yes Bryan did give me a call this morning and said that i could return the Lyric to LR Baggs but suggested that I contact the seller to see if they will do an exchange as it might be faster.
        I have contacted the seller and I will see what they have to say and then I can proceed with the next step.
        Thanks to you and Bryan for your help and I will let you know when I hear from the seller.

        Ed
        Hi
        Just had my tech put in a new Lyric yesterday. It sounds great, but as soon as I tried to change the volume it was scratchy and noisy as if the pot was full of dirt or something. Musicians friend is sending me another one. But I was wondering what goes. Also the adhesive on the back of the wire tabs and control seems to be weak. Just wondering what is causing the problem. Anyone had the same problem?

        Thanks.

        Comment


        • #5
          Originally posted by Skyhooks View Post
          Hi
          Just had my tech put in a new Lyric yesterday. It sounds great, but as soon as I tried to change the volume it was scratchy and noisy as if the pot was full of dirt or something. Musicians friend is sending me another one. But I was wondering what goes. Also the adhesive on the back of the wire tabs and control seems to be weak. Just wondering what is causing the problem. Anyone had the same problem?

          Thanks.
          The problem was me! I was using an xlr cord and the lyric just doesn't like going into the microphone socket. It is just fine with regular quarter inch cable. Customer service at or Baggs was very helpful!

          Comment


          • #6
            Hey Skyhooks,
            Thanks for sharing! I'm glad that our team was able to help.

            Comment

            Working...
            X