Announcement

Collapse
No announcement yet.

Anthem piezo sounding dull and is feedback sensitive

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anthem piezo sounding dull and is feedback sensitive

    I have the Anthem system in my Martin HD16R LSH and the piezo michrophone is sounding dull as if someone put a blanket over the sound. It is also very feedback sensitive. When I adjust the system to use the true mic the treble is there but the boominess and feedback sensitivity is still present.

    EDIT: Nevermind, the guy that installed the system obviously didnt touch the level of the true mic at all so I have been playing with the piezo only until now. It is now fixed and I can hear the mic for the first time. The feedback is still present tho so that is probably due to the guitars resonance. Or do you have any other suggestion on how to fix it? I can kind of resolve it by changing the phase each time I play a song depending on the key but it would be nice if there was some kind of a general solution to this issue so all ideas are welcome
    Last edited by mikaellavrell; 08-14-2019, 10:44 AM.

  • #2
    Hey Mikael,
    Thanks for posting.

    I am glad to hear that you figured out the mic trim. It definitely makes a huge difference.

    As for the feedback, you might want to check and make sure that the installer anchored the Piezo pickup in the guitar correctly. The pickup should be held by a wire clip to the guitar top, usually within an inch or two of where the pickup comes out of the saddle slot. Anchoring the pickup like this keeps it from being overly microphonic, causing additional feedback. I've attached a picture of the specific clip for reference.

    I hope it helps.

    EDIT: I can email a higher quality picture if needed. The forum cuts the file size down a lot.

    Comment


    • #3
      Originally posted by Caleb_Elling View Post
      Hey Mikael,
      Thanks for posting.

      I am glad to hear that you figured out the mic trim. It definitely makes a huge difference.

      As for the feedback, you might want to check and make sure that the installer anchored the Piezo pickup in the guitar correctly. The pickup should be held by a wire clip to the guitar top, usually within an inch or two of where the pickup comes out of the saddle slot. Anchoring the pickup like this keeps it from being overly microphonic, causing additional feedback. I've attached a picture of the specific clip for reference.

      I hope it helps.

      EDIT: I can email a higher quality picture if needed. The forum cuts the file size down a lot.
      So according to this photo my cable doesnt seem to be anchored correctly?

      Comment


      • #4
        From that picture, the pickup is not anchored correctly.

        Comment

        Working...
        X