Announcement

Collapse
No announcement yet.

Stage Pro Element Battery Light Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stage Pro Element Battery Light Issue

    I have a Larrivee LV-03 that came with the L.R.Baggs Stage Pro Element factory installed. Until recently it has always been played acoustically.

    A month or so ago I picked up a Yamaha THR5A amp to play around with. At or around the same time I noticed that the red battery indicator light stays on unless I am either in tuner mode or the guitar is plugged into the amp.

    I have put fresh Duracell batteries in and the light still stays lit. The preamp is working as the THR5A is getting the signal and working as it should.

    I can't say for sure that this only started when I got the amp as I sort of recall noticing the red light earlier but can't say for certain of the timing.

    At this time I remove the battery from the guitar after each use or the light will stay lit, probably until the battery is drained. I don't remove the battery until I have unplugged the guitar from the amp.

    Any help with this issue would be greatly appreciated.

  • #2
    Hey Mike,
    Thanks for posting.

    It definitely seems like something is wrong. If you can, I would try loosening the strings and disconnecting the right-angle plug at the back of the preamp. If the light turns off, then the output jack is bad. If the light stays on, there's something wrong with the preamp.

    If you want to try that out and let me know what you find at [email protected], I will do what I can to help.

    Comment


    • #3
      Caleb,

      Thanks for the feedback. I will give that a try and report back.

      Mike

      Comment

      Working...
      X