Announcement

Collapse
No announcement yet.

Element no output

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Element no output

    The factory-installed LR Baggs Stagepro Element Preamp EQ Chromatic Tuner w/ Acoustic Guitar Pickup on my Breedlove C25 stops output suddenly. What can I do?

  • #2
    Hey Buu Chung,
    Thanks for posting.

    I replied to the email you sent earlier this morning. If you want to get back to me and answer a few questions, I will gladly do what I can to help.

    Comment


    • #3
      Per instructions from Caleb Elling of LR Baggs, I sent the preamp to LR Baggs for repair. It has been over a week since the package was delivered, but I have not heard from Caleb at all. Anyway, I am so thankful for his consideration of repairing the preamp.

      Comment


      • #4
        Originally posted by Buu Chung View Post
        Per instructions from Caleb Elling of LR Baggs, I sent the preamp to LR Baggs for repair. It has been over a week since the package was delivered, but I have not heard from Caleb at all. Anyway, I am so thankful for his consideration of repairing the preamp.
        Sorry I didn't get back to your email by the end of the day on Friday. And then we were closed over the weekend.

        I just replied a few minutes ago with an update.

        Comment


        • #5
          Thank you so much. Caleb Elling is the best. I received the Element preamp replacement today. Best customer service. Thank you.

          Comment

          Working...
          X